Back to overview
Downtime

Service Disruption - Major Outage

Jun 12 at 06:27pm UTC
Affected services
API
Dashboard

Resolved
Jun 12 at 09:11pm UTC

Google Cloud has confirmed recovery in US regions and expects full recovery in less than an hour. All SlashID services are operational with no measurable disruption at this time.

We will continue to monitor our services for any sign of regression.

Thank you for your continued patience and understanding.

Updated
Jun 12 at 08:48pm UTC

All SlashID systems have recovered in all regions.

Google Cloud is still investigating the issue and at this time has not provided definitive information on the resolution nor an ETA for full recovery.

We will continue to monitor the fix and will provide another update within the next 60 minutes or as soon as we have more information.

Thank you for your continued patience and understanding.

Updated
Jun 12 at 08:09pm UTC

Systems in all regions except us-iowa seem to have fully recovered, but we do not have an ETA on full mitigation at this point.

We will continue to monitor the rollout of the fix in the recovered regions and will provide another update within the next 60 minutes or as soon as we have more information. Thank you for your continued patience and understanding.

Updated
Jun 12 at 08:01pm UTC

The major outage across all services is still ongoing. We continue to experience widespread internal errors from our cloud provider, Google Cloud Platform (GCP).

We have confirmation from Google's engineering team that the issue is recovered in some locations, but we do not have an ETA on full mitigation at this point.

Google Cloud is still investigating this issue with the highest priority, and we remain in direct communication with their teams. We sincerely apologize for the continued impact on your operations.

We will provide another update within the next 60 minutes or as soon as we have more information. Thank you for your continued patience and understanding.

Updated
Jun 12 at 06:52pm UTC

Google's engineering team has identified the source of the issue. Multiple GCP products in all GCP supported regions are experiencing impact due to an outage of the internal Identity and Access Management Service.

We will provide another update within the next 60 minutes or as soon as we have more information. Thank you for your continued patience and understanding.

Created
Jun 12 at 06:27pm UTC

We are currently experiencing a major outage across all services. Our monitoring indicates that the underlying cause is widespread internal errors from our cloud provider (Google Cloud Platform).

We are actively investigating this issue with the highest priority and are in direct communication with Google Cloud to resolve it as quickly as possible. We understand the critical nature of our service to you and sincerely apologize for the significant disruption this is causing.

We will provide another update within the next 60 minutes or as soon as we have more information.

Thank you for your patience and understanding.