Back to overview

Service Status Update – AWS Incident Impact

Oct 20 at 09:31am UTC
Affected services
API
Dashboard

Resolved
Oct 20 at 09:31am UTC

We are writing to inform you of an ongoing incident affecting Amazon Web Services (AWS), which has also disrupted our direct communication channel with enterprise customers, Slack.

Current Status:

SlashID's production systems are hosted on Google Cloud Platform (GCP) and are currently operating normally. Your authentication services remain fully operational and unaffected at this time.

Monitoring & Transparency:

While we cannot entirely exclude the possibility of downstream impact to GCP services given the scale of this incident, we are actively monitoring the situation and remain prepared to respond immediately should any changes occur.

We will provide further updates as additional information becomes available.